Opticallimits

Full Version: Custard on my face??
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3
  Ok guys,

                  You know the old saying pride comes before a fall,  all those "Grey market" deals that I was so happy with,  can you guess??

  You got it my D500 has died, well sort of.......last night I put in the new FW and everything went well, this morning charged and ready to go I was shooting a flock of flamingos, then I went to chimp....and

 

  the rear screen is dead! 

 

        At least it's a mass of lines all jumbled and unusable, the camera still functions and takes pictures....but you know....like it's useless!

 Wowcamera give a one year guarantee but it would have to go back to Asia or wherever it needs to go, a friends Sigma Port took 16 weeks before he got it back!! (it also got lost)

 So I rung Nikon UK just to see what they had to say, I told them it was grey market and of course they said there was no guarantee, I asked if they would repair it and they said, "Yes but you have to pay!"

 Anyway I'm fairly sure it's the video card driver circuitry and I would be surprised if this circuitry was not on the main board. You can still see chopped up sections of the menu so before the VCD, all functions fine.

   I told the guy what I thought and asked in a worst case scenario what would the cost of a new complete board, the guy finally agreed to ask the service manager what the cost would be for a new board. he took my email details and said he would ask and send me an email assap.

 A couple of hours later I got the mail and the quoted price was around £320 ex postage. The dilemma is, do I send the camera back to Asia to be serviced and risk being mucked about or losing the camera mysteriously in between locations etc. or,  do I cough up the "money" and get my camera in two or three weeks.  

   I was quickly looking on line at official market D500s, they are over €2100 approx. Grey market versions are now €1,550...frankly there's something dodgy going on. So you pays your money and you take the risk.....or not.

  I knew what risks I was taking so think I'm going to pay the repair at least it's guaranteed.......

 

 

    Now you can all laugh and say I told you so!

 

   PS. The FW update and the screen fault were probably unconnected! 

I am very sorry to read that, but I don't think this has anything to do with grey market deals. I don't see a reason why Nikon wants you to pay their firmware malfunction - it's not as if the camera was not working before. So, basic malfunction comes from FW, not from green import. At least I don't know there are different FW depending on regions.

 

Have you tried to reset the body? There are two green marks on buttons, these buttons do a factory reset. There's another reset (I believe) which involves taking out the battery for a while. Manual? Google?

      I can't see the screen well enough to find it in the menus.

 

This is not caused by the FW IMHO, though I was reasoning to begin with that its was, this problem occurs from time to time...my old Samsung GX10 (Pentax K10) had it, the camera worked and then next time no screen. (Actually I found another GX with a broken shutter for €50, my now missed Pentax friend put the two together,then after I sold it to a friend it took a flood and a week later it came back to life). A friends Pentax K01 did the same.

  Laptop computers are notorious for it, I've had a few video cards in my computer too.

 

  

  

  Really electronics can pack up any time especially this digital stuff!

  

  Now I'm only one month away from officially being an old fart (retirement age 65) I was somewhat surprised when I rang the pensions office to find that I will get  a 60% pension....more than I thought!

  

  I don't want to be mucked about most of my first months pension will just have to go to NIkon.  

 

    This evening I think I'll drown my sorrows!

Do you want to be patted and named "poor peanut"?

 

The reset is rather simple. Switch the camera on. Push the two buttons with green dots for 5 secs. The camera should do a reboot. You could even try to reinstall firmware. At the moment it's useless anyway. I would try a bit more before I burn some dosh.

  Poor peanut,  I'm something to do with nuts!  Tongue

 

  Just done the green buttons.....nothing doing!

 

   Anyway I recognize the look of the screen, when you get all those confused lines it's the video card! 

  

     A nice bottle of Pastis seems to have made the best improvement.......you know the yellow buttons!

Why not Nikon France?

Can't they repair it ?

Also by law in France you get a six months warranty repair so you have your camera back under warranty
      I got further with Nikon UK in five minutes than with Nikon France in the several calls that I made with them, it's the officialdom, "we can't say" ...."send it in" etc.

     If it costs 12-15 euros more in postage to have the repair done by people with whom you can discuss things sensibly, then that is well worth it in my view.

  

 I hate corporate officialdom....of course it depends on the understanding of the person you have at the end of the phone....I found no photographic rapport with Nikon France..........just political correctness..business wise.

 

    On the other hand Pentax France had one of the most sympathetic service managers I have ever come across!

 

     In the end it's who is on the end of the line......the postage difference is neither here nor there.

 

   Lastly all work done by Nikon carries a guarantee, which is why Nikon will not repair water damaged cameras, 

  After emailing Priceminister a site which  hosts many grey market companies in my case Wowcamera, they send a standard reply stating that you click on your "all your purchases" list to link in to the actual seller.....

 

        ....magically my D500 was not on the list, it seems that once their 14 day sale or return policy expires they remove it. All my other purchases were listed clear as day.

 

Wowcamera replied, that I had to go through Priceminster.....

 

         ......A nice little catch 22 system they've got going there!

 

    

 Anyway the camera went off yesterday to Nikon UK, the Nikon guy actually asked an engineer for the cost of a main board change and emailed it to me ,  Â£320 frankly I thought it would have been more.....now just the wait!

Bummer.

 

I still don't get it: That apparently is a Nikon problem. You were not mistreating your camera else than update firmware. Grey or not, that's very unfair.

  Where did you see that it's a problem?

 

 I downloaded the FW from Nikon's official site, I don't think it had anything to do with FW update to be honest, just a suspicious coincidence.

  Anyhow, do you think Nikon would admit it was their FW? I've not seen one other mention of it in the forums.
Pages: 1 2 3