• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Forums > Back > 600 EX RT not firing on 7D , working fine on other bodies
Can't find  logic reason behind it.

600EX RT is emitting AF assist beam, zooming with the lens on 7D however when it comes to shooting it doesn't fire, I cleaned the contacts on camera and flash, nothing changed, worst 580EX works normally on 7D, 600EX works normally on 750D !!!

Anyone has an idea what's going on ? how  to get the flah to fire again ??

If the other flashes are working on the 7D, surely it can't be the custom function disabling flash?..
<p style="margin:0cm;">Which Firmware  version has Canon 7d?

<p style="margin:0cm 0cm .0001pt;">If you call canon they will answer you- Please update to the latest firmware. it seems that something is solved in Canon7d FW version 1.0.9

<p style="margin:0cm 0cm .0001pt;"> 

<p style="margin:0cm 0cm .0001pt;">PS: It happens similar to my 50d and 430EX MK2 flash. Solved after update. it was clearly mentioned in release notes.

the problem it was working normally on 7D before

tried it zooms with lens and transmits all the info but does not fire, same on 5D and 30D


Forum Jump:

Users browsing this thread: 2 Guest(s)