Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
I rejoin the system 16 years later...
#11
(11-14-2022, 03:38 PM)Rover Wrote:
(11-14-2022, 02:58 PM)toni-a Wrote: My worry is that you are exploiting only a tiny bit of Z9 potential with lenses used through adapter, you will see yourself moving to native mount soon

Why is that? The AF is very fast and seemingly precise. Of course the proof will be in the action, but hopefully I'll have the opportunity for testing soon.

And no, I don't intend to switch all my lenses to the native mount - I intend to keep the 1D as well. Besides, it would take another huge investment of money I simply don't have now, and hardly will in the next couple of years. Some of my Canon gear is unsellable anyway because it's so worn and old (at least three of the lenses, anyway - the 14, the 70-200, the 100-400).

My experience adapting Canon lenses to Sony wasn't encouraging, every lens behaved differently :
10-18 no functionning at all, 17-55 focus errors, 50f1.4 focus  hunting,  85f1.8 good but slow, 28f2.8 good but still slow, that's why I dropped the idea completely. OTOH Canon EF lenses adapted to EOS RP work perfectly, well just like they used to do on EF Canon SLRs 
When you get a beast like Z9 with world class autofocus abilities you won't be exploiting the camera full potential when it comes to autofocus speed with adapted lenses, unless the adapter is really really good or adapter/camera body firmware allow them to work together in a very good way.
#12
Uh, that's why I read a lot of materials and chose (apparently) the best available adapter. The 9 lenses that I've tested so far all work, only the 14mm had issues (resolved by updating the firmware in the adapter), and the Tamron 70-300 either has defective IS or just doesn't like to be put on a camera with IBIS unless the in-lens stabilization is turned off. All focus quickly and with good accuracy, in line with what I've had on Canon (I only tested them inside in questionable light BTW, except the 16-35 which showed itself well outside).
#13
The Z9 handled the first "serious" shoot today. It went well though unfamiliar controls are still a bane, and it's awkward to change lenses a little, what with having to turn the camera off and on before swapping them (otherwise the adapter remains reporting the aperture of f/1 that doesn't change unless you, you guessed it, turn the camera off and on again). An ergonomic issue of note is the tiny "OK" button that is very hard to push while wearing thick gloves, and I had to wear these because I felt stupidly cold after waiting for 2 hours before the event had started in earnest. (it was just -6 but after 2 hours it was no consolation).

Two more lenses tested to work with the Z9 / Fringer adapter without issue, the Canon 24-70/4 L IS and the Tamron 100-400/4.5-6.3 VC. At this point I'm not expecting any hiccups unless I try something truly exotic, like an electronic MF / USM lens from the dawn of the Canon system (like the 50/1.0 or 200/1.8), or really a very old Sigma lens known for causing errors on more modern bodies. Even the Sigma 14/2.8 has been reined in.
  


Forum Jump:


Users browsing this thread:
1 Guest(s)